Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Buddy
    Join Date
    15.01.2010
    Posts
    130

    Default [Help] Bot does not use special abilities

    Guys,

    I am lost and need your help. Since the upgrade to #300 my bot is not working properly anymore and is not using any skills during a fight anymore. Let me give you some details about my setup:



    - DB #300

    - Plugins:

    Trinity 1.7.2.1 + new trinity combat routine 1.1

    MyBuddy.Local



    What works fine:

    The bot is attacking mobs with the standard left-mouse-button attack, using potions, looting items, etc.



    What doesn?t work:

    The bot is not using any abilities in the other slots at all. So during a fight it is just using the left button attack and nothing else. I tested two chars, a barbar and a demon hunter and having the same problem with both chars.



    Before I updated to #300 and the new trinity version everything was working absolutely fine. I installed a fresh copy of DB #300 and the plugins . In trinity I did not change any of the settings at all. I also tested the Belphegor routine but had exactly the same problem that the bot is not using the special abilities.



    I am currently not at home and therefore I cannot paste a log but I will do this tonight. In the meanwhile does anyone have an idea what is going wrong here?



    Many thanks for your help!

  2. #2
    Super Moderator
    Legen *wait for it* dary

    Join Date
    15.01.2010
    Location
    Athens,Greece
    Posts
    78,223

    Default

    use Trinity section plz, include a full log as attachment

  3. #3
    Buddy
    Join Date
    15.01.2010
    Posts
    130

    Default

    Was not sure where to post it because I have the same problem with the Belphegor routine. I don't think that this problem is related to Trinity.

  4. #4
    Super Moderator
    Legen *wait for it* dary

    Join Date
    15.01.2010
    Location
    Athens,Greece
    Posts
    78,223

  5. #5
    Buddy
    Join Date
    02.02.2013
    Posts
    134

    Default

    Sorry, have to post from a friend's account but here is the log file as requested:
    Attached Files Attached Files

  6. #6
    3rd Party Developer

    Join Date
    11.07.2010
    Posts
    2,631

    Default

    Try without MyBuddy.Local and see if that helps. I'm seeing some really strange stuff in your log file that isn't coming from either Trinity nor Demonbuddy.

  7. #7
    Buddy
    Join Date
    02.02.2013
    Posts
    134

    Default

    I deleted MyBuudy and just using Trinity. The bot still doesn't use any abilities.

    I also installed a fresh copy of DB 300 without any plugins and using Belphegor. Same problem, the bot is not fighting and not even with the primary attack.

    I attached both logs.

    To test it I just started the bot and manually walked into some mobs.
    Attached Files Attached Files
    Last edited by itraxx; 15.02.2013 at 18:27.

  8. #8
    Buddy
    Join Date
    02.02.2013
    Posts
    134

    Default

    Okay I tested now many different things and it seems to me that the bot is just not using special abilities anymore as soon as the chars are in a group. I know it sounds strange but from all my testing this seems to be the problem. Before #300 everything was working fine but since then the bot has issues to execute commands in a group.

    Can some please try to replicate this bug and try the bot in a group? Just invite another char, start both bots and run with one char manually to a mob and see what happens.

  9. #9
    Super Moderator
    Legen *wait for it* dary

    Join Date
    15.01.2010
    Location
    Athens,Greece
    Posts
    78,223

    Default

    looks like Trinity does not support party botting

  10. #10
    Buddy
    Join Date
    02.02.2013
    Posts
    134

    Default

    Well, also Belphegor doesnt work but both plugins always worked before the update to #300. So I guess it has to do with DB and not Trinity.

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •