Results 1 to 1 of 1
  1. #1
    Buddy
    Join Date
    15.06.2012
    Posts
    49

    Default [Loot Rules] Salvage Help?

    Hi, i'm using this item rule and i need help with salvage items

    http://www.thebuddyforum.com/demonbu...er-things.html

    PHP Code:
    <?xml version="1.0" encoding="utf-8" ?> 
    <!-- 
    Set your bot settings and allow at least one page to deposit looted items.  
    Otherwise bot will just stand front of stash and do nothing. 
    --> 
    <ItemRules name="Default Item Rules" useRoundedValues="false"> 

      <Priority priority1="Keep" priority2="Salvage" priority3="Sell" /> 

      <Categories> 
        <Category ruleType="PickUp"> 
           
          <!-- Pick up all magic+ items --> 
          <ItemRule> 
            <StatRules> 
              <Rule quality="Magic1" /> 
            </StatRules> 
          </ItemRule> 

          <!-- Pick up gold, at least in stacks of 50 --> 
          <ItemRule itemName="Gold" stack="50" /> 
           
          <!-- Pick up all pages and tomes, blacksmithing/jewelcrafting --> 
          <ItemRule itemName="Page of*" stack="1" /> 
          <ItemRule itemName="Tome of*" stack="1" /> 
           
          <!-- Pick up designs and plans, blacksmithing/jewelcrafting --> 
          <ItemRule itemName="Plan:*" stack="1" /> 
          <ItemRule itemName="Design:*" stack="1" /> 
           
          <!-- Gems --> 
          <ItemRule itemName="*Ruby*" stack="1" /> 
          <ItemRule itemName="*Emerald*" stack="1" /> 
          <ItemRule itemName="*Topaz*" stack="1" /> 
          <ItemRule itemName="*Amethyst*" stack="1" /> 

          <!-- Mythic Health potions --> 
          <ItemRule itemName="Mythic Health Potion" stack="1" /> 
        </Category> 

        <Category ruleType="Keep"> 
         
          <!-- Keep designs and plans, blacksmithing/jewelcrafting --> 
          <ItemRule itemName="Plan:*" /> 
          <ItemRule itemName="Design:*" /> 
           
          <!-- Just in case keeps pages, tomes and salvage materials--> 
          <ItemRule itemName="Page of*" /> 
          <ItemRule itemName="Tome of*" /> 
          <ItemRule itemName="*Essence" />     
          <ItemRule itemName="*Tear" /> 
          <ItemRule itemName="*Hoof" /> 
          <ItemRule itemName="*Brimstone" />     
           
          <!-- Keep rare items level 55 or more regardless of stats. -->     
          <ItemRule description="Rare Items"> 
            <StatRules> 
              <Rule quality="Rare4" stat="level" minValue="50" /> 
            </StatRules> 
          </ItemRule> 
           
          <!-- Keep legendaries, regardless of stats. --> 
          <ItemRule ruleType="Keep" description="Legendary"> 
            <StatRules> 
              <Rule quality="Legendary" /> 
            </StatRules> 
          </ItemRule> 
        </Category> 
         
        <!-- Salvages everything between level 59 and 60. --> 
        <Category ruleType="Salvage"> 
          <!-- Salvages jewelry level 59 --> 
           
          <ItemRule itemBaseType="Jewelry" description="Salvage Jewelry"> 
            <StatRules> 
              <Rule quality="Magic1" stat="level" minValue="59" /> 
            </StatRules> 
          </ItemRule> 
           
          <!-- Salvages everything else level 60 --> 
          <ItemRule description="Salvage Everything"> 
            <StatRules> 
              <Rule quality="Magic1" stat="level" minValue="60" /> 
            </StatRules> 
          </ItemRule> 
        </Category> 
         
        <!--Sells everything else --> 
        <Category ruleType="Sell"> 
          <ItemRule description="Sell Everything"> 
            <StatRules> 
              <Rule quality="Magic1" /> 
            </StatRules> 
          </ItemRule> 
        </Category> 
      </Categories> 
    </ItemRules>



    i Have this problem:

    Both my demon hunter and monk will not salvage items. I'm doing Sarkoth runs, and when its time to salvage or sell,they both just run up to the blacksmith. After a few seconds, they'll run back towards the town portal a little, and run back to the blacksmith. This continues in a loop, even if I stop the bot and start it again or quit out and start a new game.
    The only way around it is to stop the bot, manually salvage my blue items and then start the bot and it continues as normal... untill it's time to sell and salvage again.

    The problem happens with all 3 sets of rules in this thread.

    I tried with this profiles:

    http://www.thebuddyforum.com/demonbu...m-profile.html
    http://www.thebuddyforum.com/demonbu...ile-1-0-a.html
    http://www.thebuddyforum.com/demonbu...king-monk.html

    Anyone know why this is happening or where is the problem?I think that can be DB problem.
    Last edited by Loula; 16.06.2012 at 10:35.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •