• Visit Rebornbuddy
  • HB ARCHIVES: Navigation/mesh errors and problems - POST THEM HERE!--DO NOT DELETE!

    Discussion in 'Archives' started by Kickazz006, Jul 26, 2012.

    1. tynody

      tynody New Member

      Joined:
      Oct 20, 2012
      Messages:
      9
      Likes Received:
      0
      Trophy Points:
      0
      [Edited by Highvoltz on Dec 29, 2014] End point is off mesh.
      [HR][/HR]

      Running the questing profile, my character ran into BRD and stopped working. It attempted to move to a location but couldn't find a way to get there so I had to manually stop the bot. Hitting start again would immediately just stop the bot.
      After leaving BRD it seemed to start working as intended and is now doing its thing. It was weird seeing my character run into BRD alone and just sit there seemingly waiting for something to happen.

      Attached is the log when it happened. I didn't think to take a screenshot but it really didnt matter - it just stood inside the entrance anyways. I tried restarting the bot and it would just immediately stop without anything happening. Once I left BRD everything started working as normal and it went out to the next quest hub like it should have.
       

      Attached Files:

      Last edited by a moderator: Dec 29, 2014
    2. yargle

      yargle Member

      Joined:
      Aug 11, 2010
      Messages:
      85
      Likes Received:
      0
      Trophy Points:
      6
      [Edited by Highvoltz on Dec 29, 2014] Fixed
      [HR][/HR]

      When completing quests from Lunzul <Bartender> in the Hearthfire Tavern in Spires of Arakk, the bot tries to navigate through the wall behind her when moving to Rorka behind Axefall. When returning attempts to path through the other side of the wall. Log/screenshots attached.
       

      Attached Files:

      Last edited by a moderator: Dec 29, 2014
    3. erinys

      erinys New Member

      Joined:
      Nov 10, 2014
      Messages:
      43
      Likes Received:
      0
      Trophy Points:
      0
      [EDITED 14-Dec-2014 by chinajade]: This post was wrongly made to the .760 Release thread. The user's issue appears to be a navigation problem in one of Reviir's profiles.
      [09:03:28.681 D] Could not generate path from {388.006, -465.0595, -7.552288} to {448.0042, -414.619, 0.4160985} on map Draenor (Phase: SMVAllianceGarrisonLevel2new) (time used: 0 milliseconds) @ FindEndPoly

      [HR][/HR][Edited by Highvoltz on Dec 29, 2014] End point is in air
      [HR][/HR]


      Heya,

      Was referred here by this topic:
      https://www.thebuddyforum.com/thebu...m-omation-complete-lacarte-3.html#post1773312

      HB stops moving a LOT, mostly after 2-5 minutes it will hang on "moving to next hotspot" and then it wont do that.
      Could you guys take a look?

      thanks! View attachment 5388 2014-12-14 09.35.txt
       
      Last edited by a moderator: Dec 29, 2014
    4. schrodinger

      schrodinger New Member

      Joined:
      Nov 20, 2012
      Messages:
      27
      Likes Received:
      0
      Trophy Points:
      1
      GB2 Pathing Errors

      [Edited by Highvoltz on Dec 29, 2014] End point is under terrain. The profile needs fixing
      [HR][/HR]
      I'm trying to use GB2, and it stops working after a few minutes with 'Could not generate path" errors. I have attached a log.
       

      Attached Files:

      Last edited by a moderator: Dec 29, 2014
    5. thebrodieman

      thebrodieman Well-Known Member Buddy Store Developer

      Joined:
      Sep 11, 2011
      Messages:
      6,015
      Likes Received:
      77
      Trophy Points:
      48
      [Edited by Highvoltz on Dec 29, 2014] There is no mesh under this gameobject. Use a direct moveto to a location beside the gameobject
      [HR][/HR]

      Path search from {-109.8406, -657.2776, 16.40182} to {-186.8073, -710.8698, 10.05482} was aborted due to HB stopping (time used: 0 milliseconds)

      Shadowmoon Valley (Draenor)
      Can't navigate to the ritual stone at said location. Tries to navigate INSIDE the stone, not near it to interact with it.
       
      Last edited by a moderator: Dec 29, 2014
    6. thebrodieman

      thebrodieman Well-Known Member Buddy Store Developer

      Joined:
      Sep 11, 2011
      Messages:
      6,015
      Likes Received:
      77
      Trophy Points:
      48
      [Edited by Highvoltz on Dec 29, 2014] Fixed
      [HR][/HR]


      <Hotspot X="-73.41698" Y="-552.0333" Z="25.23983" />

      Several objects on the grounds here:
      <GameObject Name="Iron Horde Wagon" Entry="227133" X="-72.75868" Y="-551.1632" Z="23.50013" />
      <GameObject Name="Iron Horde Crate" Entry="225650" X="-71.98785" Y="-550.1563" Z="25.15192" />
      <GameObject Name="Iron Horde Crate" Entry="225650" X="-71.67709" Y="-549.9827" Z="27.32902" />

      Bot tries to jump up on to this wagon and run through it to continue onwards (even with it blackspotted). Bot will jump up on, but can't get back off. No anti-stuck, no jumping just stuck in a wall.
       

      Attached Files:

      Last edited by a moderator: Dec 29, 2014
    7. y2krazy

      y2krazy Community Developer

      Joined:
      Jun 21, 2011
      Messages:
      2,802
      Likes Received:
      64
      Trophy Points:
      48
      [Edited by Highvoltz on Dec 29, 2014] Fixed
      [HR][/HR]

      IMPORTANT NOTE: I HAVE SEEN AT LEAST A DOZEN OTHER PLAYERS GETTING STUCK AT THIS EXACT SPOT IN AXEFALL.

      [​IMG]

      Axefall Inn, Spires of Arak

      While attempting to run out of the building, the character simply tries to run through the wall. This has happened on every character I've leveled in Draenor.

      Approximate location in the screenshot above:

      <Hotspot X="-339.8936" Y="2270.607" Z="28.7432" />

      Log attached:
       

      Attached Files:

      Last edited by a moderator: Dec 29, 2014
    8. tat2devil

      tat2devil Member

      Joined:
      Apr 10, 2013
      Messages:
      61
      Likes Received:
      0
      Trophy Points:
      6
      Last edited by a moderator: Dec 29, 2014
    9. dmac21

      dmac21 New Member

      Joined:
      Nov 6, 2014
      Messages:
      61
      Likes Received:
      0
      Trophy Points:
      0
      forge of souls not flying back to instance after death

      [Edited by Highvoltz on Dec 29, 2014] Not a proper mesh report. I need locations and name of map
      [HR][/HR]

      View attachment 5124 2014-12-24 22.57.txt like title says , not sure if profile is the issue or HB can PM profile if needed seems it cant navigate back from rez point to target instance forge of souls.. help!:)
       
      Last edited by a moderator: Dec 29, 2014
    10. rpwrpwrpw

      rpwrpwrpw New Member

      Joined:
      Dec 24, 2014
      Messages:
      25
      Likes Received:
      0
      Trophy Points:
      0
      [Edited by HighVoltz on Jan 25 2015] This has been fixed
      [HR][/HR]

      Lvl3 ally garrison. Only item completed before starting TheBrodieman's garrison full clear was picking up completion follower missions. the first attached pic starting point is where the plugin was started, the second attached pic is the stuck point. toon went to this corner, pauses for 30 seconds, then moved to the left enough to pick up apex daily, then returned to the corner and just stood there. log file attached as well. similar results with other toons.
       

      Attached Files:

      Last edited by a moderator: Jan 25, 2015
    11. tumbum

      tumbum Active Member

      Joined:
      Mar 17, 2011
      Messages:
      3,341
      Likes Received:
      10
      Trophy Points:
      38
      [Edited by HighVoltz on Jan 25 2015] This doesn't indicate that there was a mesh issue. If bot was not misbehaving then simply ignore.
      [HR][/HR]
      Frostfire Ridge

      never saw this

      Maybe its wrong here. If so delete the Post please.
       
      Last edited by a moderator: Jan 25, 2015
    12. thebrodieman

      thebrodieman Well-Known Member Buddy Store Developer

      Joined:
      Sep 11, 2011
      Messages:
      6,015
      Likes Received:
      77
      Trophy Points:
      48
      [Edited by HighVoltz on March 19, 2015] Fixed
      [HR][/HR]



      Inside Molten Core (Vanilla version) the bot reaches a point somewhere between:
      X="930.6266" Y="-609.0004" Z="-203.6087"
      and
      X="832.4578" Y="-611.9365" Z="-202.7255"

      and then decides that "I think it would be a good idea to enter this nearby pool of lava...which is a dead end" and subsequently dies (since lava damage is now % damage)

      Log does not show any "unable to path" or such errors, it truly thinks this is the best path.

      Location of lava pool entrance: X="1008.857" Y="-701.6511" Z="-182.3996"
      Location of pool: X="946.1535" Y="-698.6436" Z="-206.0063"

      Please contact me if you need more information.
       
      Last edited by a moderator: Mar 19, 2015
    13. Fgame

      Fgame Member

      Joined:
      Oct 2, 2014
      Messages:
      301
      Likes Received:
      0
      Trophy Points:
      16
      [Edited by HighVoltz on Feb 17, 2015] Not enough information was given. We need the location and map name too
      [HR][/HR]
      He does not avoid these Objects. as butoh they do not exist
      bot permanently stuck in those boxes and here in this wagon.
      Well, it happens very often. Lock the space around them please.
       

      Attached Files:

      Last edited by a moderator: Feb 17, 2015
    14. thebrodieman

      thebrodieman Well-Known Member Buddy Store Developer

      Joined:
      Sep 11, 2011
      Messages:
      6,015
      Likes Received:
      77
      Trophy Points:
      48
      [Edited on Jan 15 2015 by HighVoltz] This is now fixed
      [HR][/HR]
      Space Mummies building in Ashran - Horde is unmeshed. Contains Orgrimmar Portal. Unable to nav into building.
      Location: X="5278.353" Y="-4038.777" Z="18.31569"
       
      Last edited by a moderator: Jan 15, 2015
    15. lttlmantate1

      lttlmantate1 Member

      Joined:
      Oct 29, 2014
      Messages:
      31
      Likes Received:
      0
      Trophy Points:
      6
      [ level: 2 plot: 19 ] Engineering Works

      [Edited by HighVoltz on Jan 25 2015] Dynamic objects are not supported atm
      [HR][/HR]

      Having issue getting into Engineering building, keeps trying to face plant on wall.

      Need coords as well? Figured the level/plot would cover it.

      Position: <5662.57, 4540.18, 120.09>

      1_WoWScrnShot_011015.jpg
       
      Last edited by a moderator: Jan 25, 2015
    16. thebrodieman

      thebrodieman Well-Known Member Buddy Store Developer

      Joined:
      Sep 11, 2011
      Messages:
      6,015
      Likes Received:
      77
      Trophy Points:
      48
      The issue is dynamic buildings on this one. Meshing for 1 building on that plot would mesh for all of I understand correctly.
       
    17. laria

      laria Well-Known Member

      Joined:
      Jan 15, 2010
      Messages:
      5,387
      Likes Received:
      32
      Trophy Points:
      48
      Dynamic buildings are on the to-do list.
       
    18. laria

      laria Well-Known Member

      Joined:
      Jan 15, 2010
      Messages:
      5,387
      Likes Received:
      32
      Trophy Points:
      48
      [Edited by HighVoltz on Feb 17, 2015] Fixed
      [HR][/HR]
      Durotans Camp near the bridge in Talador at around <Hotspot X="2803.801" Y="2516.996" Z="120.8903" /> is a horde camp,
      My alliance toon tries to path right through it and gets repeatedly killed by the guards.
       
      Last edited by a moderator: Feb 17, 2015
    19. thebrodieman

      thebrodieman Well-Known Member Buddy Store Developer

      Joined:
      Sep 11, 2011
      Messages:
      6,015
      Likes Received:
      77
      Trophy Points:
      48
      [Edited by HighVoltz on Feb 17, 2015] It looks like a rock will block that path after outpost is build, or at some point.
      [HR][/HR]
      Talador <Hotspot X="6326.194" Y="641.4565" Z="104.4954" />

      Right next to the mole machine is a path leading up to the outpost. Before the outpost is complete (and assuming after) it won't take this path up to the outpost, but tries to path all the way around. No "partial path" or "unable to path" errors shown, HB believes going the long way around is the faster way.
       

      Attached Files:

      Last edited by a moderator: Feb 17, 2015
    20. laria

      laria Well-Known Member

      Joined:
      Jan 15, 2010
      Messages:
      5,387
      Likes Received:
      32
      Trophy Points:
      48
      [Edit by HighVoltz on Jan 25 2015] Fixed
      [HR][/HR]

      Bonfire in Arak at around <Hotspot X="163.7724" Y="1805.708" Z="23.77709" /> , not a gamebreaker but still suspicious if someone watches closely
       
      Last edited by a moderator: Jan 25, 2015

    Share This Page