• Visit Rebornbuddy
  • [Order Bot] Quests, Quests and Quests!

    Discussion in 'Rebornbuddy Profiles' started by y2krazy, May 27, 2015.

    1. bubuhubu

      bubuhubu Member

      Joined:
      Mar 2, 2013
      Messages:
      92
      Likes Received:
      2
      Trophy Points:
      8
      Since the latest update 1.0.487.0, I am getting lots of travel error while running questing profile. Here is log file. Is it Rebornbuddy issue or profile issue?
      Thanks in advance.
       

      Attached Files:

    2. enkae7317

      enkae7317 Member

      Joined:
      Aug 31, 2014
      Messages:
      300
      Likes Received:
      1
      Trophy Points:
      18
      Hey guys, have a HUGE problem. Just got back into FFXIV and booted up reborn buddy fresh install. Did the SVN and everything..and then downloaded y2crazy's heavensward profile. Long story short: getting this error.

      [07:37:20.998 N] [Heavensward] Skipping the Let the Clan Hunt Begin quest until I add the old quests in this profile...
      [07:37:21.058 V] [Poi.Clear] Reason: Current behavior changed to LogMessageTag: IsDone: False, Message: [Heavensward] Checking level 54 quests..., HighPriority: False, LineNumber: 8419, InCombat: False, QuestId: 0, StepId: 0, PostCombatDelay: 0, QuestName: null, IsDoneCache: False, Behavior: null, .
      [07:37:21.058 D] Replaced hook [ProfileOrderBehavior_Hook] df489a4e-0385-43d0-b027-953c5b458285
      [07:37:21.059 N] [Heavensward] Checking level 54 quests...
      [07:37:21.165 V] [Poi.Clear] Reason: Current behavior changed to GetTo: XYZ: <-575.8106, 48.80803, 319.44>, ZoneId: 400, IsDone: False, HighPriority: True, LineNumber: 9491, InCombat: False, QuestId: 0, StepId: 0, PostCombatDelay: 0, QuestName: null, IsDoneCache: False, Behavior: null, .
      [07:37:21.165 D] Removed all hooks from [ProfileOrderBehavior_Hook]
      [07:37:21.165 D] Replaced hook [HighPriorityProfileOrderBehavior_Hook] d9f48b6f-54ae-44f8-84f9-9cf5b651907a
      [07:37:21.278 V] [NavGraph] LocalResults
      [07:37:21.278 V] [NavGraph] 5866171 | <-55.63488, 8.113304, 48.92591> ==> <-188.7119, 14.78094, -58.3877> | CanNav:True PathLength:205.385
      [07:37:21.278 V] [NavGraph] 5866239 | <-55.63488, 8.113304, 48.92591> ==> <-153.6506, 31.2521, -142.5388> | CanNav:True PathLength:227.3492
      [07:37:21.278 V] [NavGraph] 5866243 | <-55.63488, 8.113304, 48.92591> ==> <-57.21729, 20.77625, -97.48738> | CanNav:True PathLength:148.9234
      [07:37:21.278 V] [NavGraph] 5866255 | <-55.63488, 8.113304, 48.92591> ==> <156.2872, -19.95889, 54.68155> | CanNav:True PathLength:244.6869
      [07:37:21.278 V] [NavGraph] 5866260 | <-55.63488, 8.113304, 48.92591> ==> <53.021, 29.92871, -81.33281> | CanNav:True PathLength:180.332
      [07:37:21.278 V] [NavGraph] 70 | <-55.63488, 8.113304, 48.92591> ==> <-60.45592, 11.17874, 47.49885> | CanNav:True PathLength:4.420571
      [07:37:21.278 V] [NavGraph] 80 | <-55.63488, 8.113304, 48.92591> ==> <45.8162, 24.57011, 1.003245> | CanNav:True PathLength:134.6351
      [07:37:21.278 V] [NavGraph] 81 | <-55.63488, 8.113304, 48.92591> ==> <-111.4158, 16.15517, -27.05248> | CanNav:True PathLength:112.3258
      [07:37:21.278 V] [NavGraph] 82 | <-55.63488, 8.113304, 48.92591> ==> <49.43034, -11.14312, 66.71724> | CanNav:True PathLength:131.018
      [07:37:21.409 V] [NavGraph] RemoteResults
      [07:37:21.409 V] [NavGraph] 5078 | <262.7133, -37.70464, 600.3737> ==> <-575.8106, 48.80803, 319.44> | CanNav:False PathLength:0
      [07:37:21.409 V] [NavGraph] 5079 | <-581.437, 52.87199, 316.9444> ==> <-575.8106, 48.80803, 319.44> | CanNav:True PathLength:7.375652
      [07:37:21.410 V] [NavGraph] Failure to find a path from <-55.63488, 8.113304, 48.92591> 418 to <-575.8106, 48.80803, 319.44> on 400
      [07:37:21.410 N] [GetTo] Couldn't get a path to <-575.8106, 48.80803, 319.44> on 400, Stopping.
      [07:37:21.410 N] Stopping the bot. Reason:[GetTo] Couldn't get a path to <-575.8106, 48.80803, 319.44> on 400, Stopping.
      [07:37:21.410 D] CurrentBot.Stop()
      [07:37:21.410 D] TreeHooks.Instance.ClearAll()
      [07:37:21.410 N] Clearing all hooks.
      [07:37:21.410 D] Added new hook [TreeStart] 82af1056-2c43-4aec-b592-c6a0e3da646f
      [07:37:21.410 D] Added new hook [PoiAction] 656f707e-1442-4ad2-96ab-4b7767c16361
      [07:37:21.410 D] Replaced hook [PreCombatBuff] 0eaa626d-023c-4feb-a2fb-9d81e657700e
      [07:37:21.410 D] Replaced hook [Heal] 46c94643-97ca-4efb-93c7-98a6a83f3017
      [07:37:21.410 D] Replaced hook [Pull] 01f414af-55ea-4fc5-aed0-16dc46435f32
      [07:37:21.410 D] Replaced hook [CombatBuff] 98bbec78-6416-4e0c-b8c1-d09853b6d036
      [07:37:21.410 D] Replaced hook [Combat] f39aa53b-0f0c-4e5f-82fb-eae165500a9e
      [07:37:21.410 D] Replaced hook [Rest] 09f7f23d-5693-44a3-b64e-e397dd14d17d
      [07:37:21.410 D] Added new hook [PreCombatLogic] 15a50f8a-dd91-4e49-bc93-2124bbfbea4b
      [07:37:21.410 N] [Zekken] Avoidance hooked.
      [07:37:21.410 D] Navigator.Clear()
      [07:37:21.526 V] [Poi.Clear] Reason: Bot stopped
      [07:37:21.526 D] OnStop event
      [07:37:21.526 D] OnStop Event Invoking
      [07:37:21.527 N] [EnableFlight] Stopped Flight Navigator.
      [07:37:21.527 V] [FlightNav] Putting original Navigator back!
      [07:37:21.527 N] [EnableFlight] Disposing the GaiaNavigator
      [07:37:21.528 N] Connection closed! 192.99.148.87:31215
      [07:37:21.528 N] Bot Thread Ended.
       
    3. xICEMANx117

      xICEMANx117 New Member

      Joined:
      May 5, 2014
      Messages:
      22
      Likes Received:
      0
      Trophy Points:
      1
      this is rediculas i have tried like 5 profiles and all i get is errors, is there a questing profile that works at least half way damn
       
    4. bubuhubu

      bubuhubu Member

      Joined:
      Mar 2, 2013
      Messages:
      92
      Likes Received:
      2
      Trophy Points:
      8
      With the latest Rebornbuddy update, they have made "travel" redundant, so all profile which has "travel" function require re-work.
      I guess we will have to wait until @y2krazy update profiles.
       
    5. xICEMANx117

      xICEMANx117 New Member

      Joined:
      May 5, 2014
      Messages:
      22
      Likes Received:
      0
      Trophy Points:
      1
      So basically this bot is useless till they fix it.
       
    6. zzi

      zzi Active Member

      Joined:
      Mar 10, 2016
      Messages:
      312
      Likes Received:
      45
      Trophy Points:
      28
      What profile are you running that is having issues?

      If you post logs we can help you...


      Also Dropping the TravelTag is a big deal and Y2Krazy has done an amazing job updating the main story quests to not use that particular tag. Updating the other profiles is just a matter of time.

      If you drop by the discord server we can help you with issues that you have with any of the specific profiles. Personally, I have provided updates to a profile that someone was having issues with in there. It's disappointing but these forums aren't checked all the time (something that I personally am trying to get better at)
       
    7. Shadowgate

      Shadowgate New Member

      Joined:
      Jul 20, 2014
      Messages:
      4
      Likes Received:
      1
      Trophy Points:
      3
      when i go to run the gathering profiles i get this error message
      [05:54:46.435 N] BehaviorDirectory element found, compiling custom behaviors...
      [05:54:50.923 N] Loaded profile [O] Class and Job Quests (v2.1.4)
      [05:55:36.731 N] BehaviorDirectory element found, compiling custom behaviors...
      [05:55:39.851 N] Failed to load profile: Element Travel is not supported. Please check your XML and try again. (<Travel To="131" />) Line 115
      [05:55:39.851 D] System.Exception: Element Travel is not supported. Please check your XML and try again. (<Travel To="131" />) Line 115
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(XElement , Type )
      at Clio.XmlEngine.PropertyProcessor..(XElement )
      at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
      at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
      at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
      at Clio.XmlEngine.PropertyProcessor.(XElement , PropertyInfo )
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at ff14bot.NeoProfiles.NeoProfile.Load(XElement element, String path)
      at ff14bot.NeoProfiles.NeoProfile.Load(String path)
      at ff14bot.NeoProfiles.NeoProfileManager.Load(String profilePath, Boolean rememberPath)
       
    8. zzi

      zzi Active Member

      Joined:
      Mar 10, 2016
      Messages:
      312
      Likes Received:
      45
      Trophy Points:
      28
      You are using an out of date profile. The new version of the Class and Job Quests doesn't have the Travel tag anymore.
       
    9. bubuhubu

      bubuhubu Member

      Joined:
      Mar 2, 2013
      Messages:
      92
      Likes Received:
      2
      Trophy Points:
      8
      Not really. Questing profile still works. Only Bot is having issue travelling between different maps. So if the bot stops because can't find the path, if you manually move character to the intended map and start bot again, it would work.

      Like Zzi said, Y2Krazy has done great job with class and job profile. Hopefully he will update main quest profile too when he has time.
       
    10. xICEMANx117

      xICEMANx117 New Member

      Joined:
      May 5, 2014
      Messages:
      22
      Likes Received:
      0
      Trophy Points:
      1
      What Profile isnt useless a little insight would be nice cause everytime i load a profile this is all i get.

      [09:29:57.028 N] [Job Check] Equipping your Soul Crystal now...
      [09:29:57.087 V] [Poi.Clear] Reason: Current behavior changed to RunCode: Name: EquipBLMCrystal, IsDone: False, HighPriority: False, LineNumber: 41, InCombat: False, QuestId: 0, StepId: 0, PostCombatDelay: 0, QuestName: null, IsDoneCache: False, Behavior: null, .
      [09:29:57.087 D] Exception during scheduling Pulse: System.NullReferenceException: Object reference not set to an instance of an object.
      at ff14bot.NeoProfiles.Tags.RunCode.OnStart()
      at „..()
      at ff14bot.NeoProfiles.NeoProfileManager.UpdateCurrentProfileBehavior()
      at ff14bot.BotBases.OrderBot.(Object , EventArgs )
      at ff14bot.Behavior.BrainBehavior.()
      [09:29:57.087 N] [Job Check] Equipping your Soul Crystal now...
      [09:29:57.145 V] [Poi.Clear] Reason: Current behavior changed to RunCode: Name: EquipBLMCrystal, IsDone: False, HighPriority: False, LineNumber: 41, InCombat: False, QuestId: 0, StepId: 0, PostCombatDelay: 0, QuestName: null, IsDoneCache: False, Behavior: null, .
      [09:29:57.145 D] Exception during scheduling Pulse: System.NullReferenceException: Object reference not set to an instance of an object.
      at ff14bot.NeoProfiles.Tags.RunCode.OnStart()
      at „..()
      at ff14bot.NeoProfiles.NeoProfileManager.UpdateCurrentProfileBehavior()
      at ff14bot.BotBases.OrderBot.(Object , EventArgs )
      at ff14bot.Behavior.BrainBehavior.()
      [09:29:57.145 N] [Job Check] Equipping your Soul Crystal now...
      [09:29:57.205 V] [Poi.Clear] Reason: Current behavior changed to RunCode: Name: EquipBLMCrystal, IsDone: False, HighPriority: False, LineNumber: 41, InCombat: False, QuestId: 0, StepId: 0, PostCombatDelay: 0, QuestName: null, IsDoneCache: False, Behavior: null, .
      [09:29:57.205 D] Exception during scheduling Pulse: System.NullReferenceException: Object reference not set to an instance of an object.
      at ff14bot.NeoProfiles.Tags.RunCode.OnStart()
      at „..()
      at ff14bot.NeoProfiles.NeoProfileManager.UpdateCurrentProfileBehavior()
      at ff14bot.BotBases.OrderBot.(Object , EventArgs )
      at ff14bot.Behavior.BrainBehavior.()
      [09:29:57.205 N] [Job Check] Equipping your Soul Crystal now...
       
    11. xICEMANx117

      xICEMANx117 New Member

      Joined:
      May 5, 2014
      Messages:
      22
      Likes Received:
      0
      Trophy Points:
      1

      Got a link to the discord server?
       
    12. Freiheit

      Freiheit Member

      Joined:
      Apr 23, 2015
      Messages:
      44
      Likes Received:
      26
      Trophy Points:
      18
    13. born2live

      born2live New Member

      Joined:
      Sep 13, 2015
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      1
      I'm also getting an error when trying to use a gathering 1-60 profile. Help?

      [23:17:57.324 N] Failed to load profile: Exception has been thrown by the target of an invocation. - Line: 634
      [23:17:57.324 D] System.Exception: Exception has been thrown by the target of an invocation. - Line: 634
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XAttribute , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at Clio.XmlEngine.PropertyProcessor.(XElement , Type )
      at Clio.XmlEngine.PropertyProcessor..(XElement )
      at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
      at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
      at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
      at Clio.XmlEngine.PropertyProcessor.(XElement , PropertyInfo )
      at Clio.XmlEngine.PropertyProcessor.(PropertyInfo , XElement , Object )
      at Clio.XmlEngine.XmlEngine.Load(Object obj, XElement element)
      at ff14bot.NeoProfiles.NeoProfile.Load(XElement element, String path)
      at ff14bot.NeoProfiles.NeoProfile.Load(String path)
      at ff14bot.NeoProfiles.NeoProfileManager.Load(String profilePath, Boolean rememberPath)
       
    14. Warmwater

      Warmwater New Member

      Joined:
      Oct 20, 2014
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      You could fix that yourself.
      Open Gathering(Mining)* profile (With Notepad++, or something similar) -> Go to line 634

      Now you should see a code line like this
      The problem is that the line specifies Y and Z twice.

      So the line should look like this
      Just copy and past.
      Happy Gathering!

      *Have not looked at any other then mining.
       
      Last edited: May 27, 2017
    15. zzi

      zzi Active Member

      Joined:
      Mar 10, 2016
      Messages:
      312
      Likes Received:
      45
      Trophy Points:
      28
      ooh! I might have broken it when i updated the gathering profiles for y2 >_<;;
       
    16. johblip

      johblip New Member

      Joined:
      Jun 19, 2013
      Messages:
      12
      Likes Received:
      1
      Trophy Points:
      3
      Amazing work! I've been running the HW questline profile and it very often stops in a location and I recieve the following error:

      [16:12:36.294 V] [Poi.Clear] Reason: Current behavior changed to RunCode: LineNumber: 6436, Name: SummonChocobo, IsDone: False, HighPriority: False, InCombat: False, QuestId: 0, StepId: 0, PostCombatDelay: 0, QuestName: null, IsDoneCache: False, Behavior: null, .
      [16:12:36.294 D] Exception during scheduling Pulse: System.NullReferenceException: Object reference not set to an instance of an object.
      at ff14bot.NeoProfiles.Tags.RunCode.OnStart()
      at ..()
      at ff14bot.NeoProfiles.NeoProfileManager.UpdateCurrentProfileBehavior()
      at ff14bot.BotBases.OrderBot.(Object , EventArgs )
      at ff14bot.Behavior.BrainBehavior.()


      I get past it by just advancing the quest myself but it seems to happen every 5-10 minutes now.
       
    17. Bardon

      Bardon New Member

      Joined:
      Jun 1, 2017
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      I was using this for questing yestarday and all was working fine, now it will take me to the markers etc for the quests but will not fight any mobs like it should be, any ideas?
       
    18. jrl5k

      jrl5k New Member

      Joined:
      Jan 15, 2010
      Messages:
      24
      Likes Received:
      0
      Trophy Points:
      1
      profile is stopping after trying to find the next quest to work on, any help with what I'm doing wrong would be appreciated. Thank you
       

      Attached Files:

    19. zostream

      zostream New Member

      Joined:
      Jun 5, 2017
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      hello, hopefully someone will be able to help me out with this issue. Im using the story quest bot(heavensward.xml) and it worked fine(kinda) till a point, where it started to do sidequests in the dravnian forelands. I dont know why its done this but i let it keep going the side quests and it just wont stop. i manually progressed the quest all the way to the next map and it continually goes back to this map to do sidequests, which is quite annoying, especially since some of them stop short and have to have me manually intervene. Im not sure why it keeps doing sidequests in this area but i have double and quadruple checked to make sure i have the right profile loaded. please assist.
       
    20. wish311

      wish311 New Member

      Joined:
      Jun 5, 2017
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      1
      Profile Name: [O] A Realm Reborn (Immortal Flames)
      Issue:Starting
      the profile at the quest History Repeating to travel to Umbra Isle
      <GetTo ZoneId="138" XYZ="-287.2206, -40.98314, 407.6447"/>
      isnt rechecking if it can talk to the ferry captain it stalls at its 1st location and gear checks, I am completing this quest by hand to get off the Isle to see if this resolves
      the code is there to talk to the ferry and come here once and it works but if you restart on the Isle or anywhere else it errors after porting to its 1st port chain in the start of the XML file
      Suggested Fix: add a logic for if on x quest recheck location and steps to get there if xyzdont match, im not sure honestly


      of sylphs and spriggans also had a Nav Issue going into the tree for the fight, im sure this is just a z issue and a routing the but up the tree, but if does go to the area right below the encounter.

      other than these issues this profile has been awesome!
       
      Last edited: Jun 5, 2017

    Share This Page