• Visit Rebornbuddy
  • [PLUGIN] BuddyStats - Stats and Remote Control

    Discussion in 'Buddystats' started by jimmy06, Mar 25, 2014.

    1. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      BuddyStats - Track and control your bot from everywhere! (Android & iOS Support)

      Ever wanted to check how is your bot doing while you are at work, school, on a trip or simply AFK? Now its fairly simple!

      What this plugin does?
      This plugin will allow you to track and control your bots and see how are they doing while you are at work / school or simply afk.
      Plugin will track all important stats you might be interested in and also logs all items you picked up!

      Features
      - Tracking of your bot stats
      - Remote Control (Start, Stop, Profile Switching)
      - Multi-botting support
      - Live Screenshots of your bots
      - iOS and Android Support!

      Suport us and get exclusive features:
      [​IMG] [​IMG]
      ( ~ 1.00 EUR / 1 USD )

      Exclusive Features so far:

      • remote profile switching


      Website: BuddyStats.com

      [​IMG]


      List of Tracked Stats (more stats will be added in the future):
      - Class
      - Level + XP/hr
      - Paragon Level + XP/hr *new*
      - Total Gold
      - Gold Per Hour
      - Deaths Count
      - Active profile Name
      - Looted items


      Upcoming Features:
      - None

      Installation Guide:
      1) Delete any old BuddyStats folder THIS IS IMPORTANT.
      2) Download the plugin and extract it to the DemonBuddy/Plugins/BuddyStats folder (or if the .zip contains WebStats folder, just put it in plugins ofcourse :) )
      3) Register on our website
      4) Log in, go to Profile and copy paste your API Key into Buddystats Config Window.
      5) Start the bot and enable the plugin!

      Password Resets
      Please reset your password here

      Website Changelog:

      Fixed screenshot button and Profile loading. This also should have fixed stopping and starting the bot.

      Changelog:

      v0.40
      - Fixed XP/h for XP/h > 2.14 Billion
      - Updated "Request a feature URL"

      v0.31
      - Switched from TortoiseSVN

      v0.15
      - Made auto updating easier to manage. This means the version number looks older then the prior one ignore this and continue please :)
      This should also stop the hourly crash though this is not tested.

      Current
      Developers: Jimmy06

      Old
      Developers: Guga, Creedo
       

      Attached Files:

      Last edited: Apr 11, 2016
    2. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      Known issues and possible solutions:

      1) NotSupportedException
      ERROR:
      [10:57:58.807 D] Exception while enabling plugin WebStats: System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See <loadFromRemoteSources> Element for more information.
      at System.Reflection.RuntimeAssembly.nLoadFile(String path, Evidence evidence)
      at System.Reflection.Assembly.LoadFile(String path)
      at GugaPlugin.GugaPlugin.OnEnabled() in e:\Demon\Plugins\BuddyStats\WebStats.cs:line 56
      at Zeta.Common.Plugins.PluginContainer.set_Enabled(Bo olean value)
      SOLUTION:
      Go to your BuddyStats folder, right click on WebStatsPackets.dll file and go to properties and click on the Unblock button.
      View attachment 122812

      2) Device Registration not working on Android / feature X is working on my desktop browser but not on my phone
      Please try the following:
      - Delete App cache and data from the Android Settings.
      [​IMG]
      - Make sure you are on the latest version.
      - Try pairing again.
      - Log out and back in
      - Your profile should show "Premium" now.

      3) Profiles arent selectable from the Bot view
      Make sure you put the desired profile xml files directly into the /Profiles folder, not into subfolders.

      4) Known issues (you dont need to report them, we are working on it)
       
    3. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      Ok I think I've found a work around for this.

      make a copy of the file *****.config

      [​IMG]

      Then rename it to "Demonbuddy.exe.config"
      [​IMG]
       
    4. Cassou

      Cassou New Member

      Joined:
      Apr 6, 2016
      Messages:
      14
      Likes Received:
      0
      Trophy Points:
      0
      Thx, I'm going to try that.
       
    5. Jaake

      Jaake New Member

      Joined:
      Apr 1, 2016
      Messages:
      32
      Likes Received:
      0
      Trophy Points:
      0
      Attempt to run latest demonbuddy with Trinity, Adventurer and BuddyStats plugins causing error

       
    6. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      More then likely I really uploaded the wrong file. Check the main folder for sharpsvn.dll and move it to the Buddystats folder. I'll try and upload the correct one asap.
       
    7. Jaake

      Jaake New Member

      Joined:
      Apr 1, 2016
      Messages:
      32
      Likes Received:
      0
      Trophy Points:
      0
      The .dll is in the BuddyStats folder. When I copied sharpsvn.dll to the main DemonBuddy folder, there were still errors, but much less of them

       
      Last edited: Apr 12, 2016
    8. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      Nope that's correct check the second post about blocked
       
    9. Jaake

      Jaake New Member

      Joined:
      Apr 1, 2016
      Messages:
      32
      Likes Received:
      0
      Trophy Points:
      0
      The image attachment is missing and I can't find anything related to block or unblock in the file properties.

      I'm on W10 x64 if that matters.
       
    10. napaDox

      napaDox Member

      Joined:
      Aug 3, 2013
      Messages:
      107
      Likes Received:
      0
      Trophy Points:
      16
      dont work(
       
    11. FreakyBart

      FreakyBart Active Member

      Joined:
      Sep 14, 2015
      Messages:
      527
      Likes Received:
      32
      Trophy Points:
      28
      Provide error logs, screenshots or details.
      Else, noone can help you
       
    12. DanishNinja

      DanishNinja Member

      Joined:
      Aug 31, 2014
      Messages:
      171
      Likes Received:
      0
      Trophy Points:
      16
      I am getting this error

      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\Connection.cs(164,30) : warning CS0168: The variable 'e' is declared but never used
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\Connection.cs(207,30) : warning CS0168: The variable 'e' is declared but never used
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\Connection.cs(226,30) : warning CS0168: The variable 'e' is declared but never used
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\Connection.cs(247,34) : warning CS0168: The variable 'e' is declared but never used
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\Connection.cs(332,38) : warning CS0168: The variable 'e' is declared but never used
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(74,17) : error CS0433: The type 'SvnInfoEventArgs' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(75,17) : error CS0433: The type 'SvnWorkingCopyVersion' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(76,17) : error CS0433: The type 'SvnWorkingCopyClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(76,62) : error CS0433: The type 'SvnWorkingCopyClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(77,17) : error CS0433: The type 'SvnClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(77,50) : error CS0433: The type 'SvnClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(82,17) : error CS0433: The type 'SvnRevertArgs' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(82,42) : error CS0433: The type 'SvnRevertArgs' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(83,30) : error CS0433: The type 'SvnDepth' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(99,25) : error CS0433: The type 'SvnUriTarget' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(99,49) : error CS0433: The type 'SvnUriTarget' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(113,28) : error CS0433: The type 'SvnException' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(197,17) : error CS0433: The type 'SvnClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(197,40) : error CS0433: The type 'SvnClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(200,13) : error CS0433: The type 'SvnWorkingCopyClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(200,58) : error CS0433: The type 'SvnWorkingCopyClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(201,13) : error CS0433: The type 'SvnWorkingCopyVersion' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
      Compiler Error: C:\Users\Magnus\Documents\Demonbuddy\Plugins\BuddyStats\WebStats.cs(426,37) : error CS0433: The type 'SvnClient' exists in both 'SharpSvn, Version=1.8009.3299.43, Culture=neutral, PublicKeyToken=d729672594885a28' and 'SharpSvn, Version=1.8008.3178.19, Culture=neutral, PublicKeyToken=d729672594885a28'
       
    13. screwedx

      screwedx New Member

      Joined:
      Feb 18, 2016
      Messages:
      36
      Likes Received:
      0
      Trophy Points:
      0
      Update:
      Login is possible, no data shown... bot is running for a while...



      i have a problem..
      i cannot login in webinterface (changed the password, but login not working)
      in the app (there i'm in...) i don't see the bot...

      no errors in logfile...
       
      Last edited: May 4, 2016
    14. Lexsor

      Lexsor New Member

      Joined:
      May 16, 2014
      Messages:
      9
      Likes Received:
      0
      Trophy Points:
      0
      So when I startup the bot after a fresh install of BuddyStats, It builds all of the plugin stuff in the BuddyStats folder. Unfortunately, it doesnt allow me to edit the config file, nor does it show up under the plugin tab on the bot.

      I am not receiving any errors from the bot and I think the only thing I need to do is add my API to the config file. If anyone has an idea what should be done please let me know.
       
    15. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      Post a log file for buddystats
       
    16. Lexsor

      Lexsor New Member

      Joined:
      May 16, 2014
      Messages:
      9
      Likes Received:
      0
      Trophy Points:
      0
      So I looked through the log and it appears much like the one posted above. It talks about a variable 'e' not being used which i believe is the API I spoke about before. I remember about a year ago when I used the BuddyStats plugin I would have to associate the API from the website into the plugin itself, but currently I can't find that anywhere in the BuddyStats plugin folder. I have attached my Log so that you can check it out when you get a chance.


      Log---> View attachment 6728 2016-05-05 18.41.txt
       
    17. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      Your using ezupdater right. If so you could try deleting the sharpsvn.dll from the Buddystats folder. The problem you have is its double loading sharpsvn.dll
       
    18. Lexsor

      Lexsor New Member

      Joined:
      May 16, 2014
      Messages:
      9
      Likes Received:
      0
      Trophy Points:
      0
      Thanks Jimmy,

      I believe we are getting there. All of the errors that I could see for the BuddyStats are now gone. The issue I am now having is the website isn't updating the stats from the bot. Most current log has been uploaded.

      Log --> View attachment 11716 2016-05-05 19.21.txt
       
    19. Lockoff

      Lockoff New Member

      Joined:
      Feb 14, 2016
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      0
      So I did everything got rid of BuddyStats folder made new one and downloaded the plug in and was able to put in the API key, it says No Active bot found...
       
    20. jimmy06

      jimmy06 Moderator Staff Member Moderator

      Joined:
      May 12, 2010
      Messages:
      824
      Likes Received:
      20
      Trophy Points:
      18
      More sure you disable and re-enable the plugin after changing the api key :)
       

    Share This Page