Demonbuddy for Season 16 released, updates.buddyauth.com !
  • Visit Rebornbuddy
  • Visit Demonbuddy

R-YAR - rrrix's YAR fork

Discussion in 'Plugins' started by rrrix, Mar 14, 2013.

  1. Xenetron

    Xenetron Member

    Joined:
    Mar 5, 2013
    Messages:
    627
    Likes Received:
    4
    Trophy Points:
    18
    I have D3 crash on game creation on TWO specific bots (out of around 10)

    They continously crash no matter what version of DB, trinity, etc.

    Just CRASH 100% of the fucking time.

    Anyone else got this? Starting to think it's YAR since it gives me a YAR error:

    Exception during bot tick.System.Exception: Only part of a ReadProcessMemory or WriteProcessMemory request was completed, at addr: 01D895DC, Size: 4
    at GreyMagic.ExternalProcessMemory.ReadByteBuffer(IntPtr addr, Void* buffer, Int32 count)
    at GreyMagic.MemoryBase.Read[T](IntPtr addr)
    at GreyMagic.MemoryBase.Read[T](Boolean isRelative, IntPtr[] addrs)
    at Zeta.Game.ZetaDia.get_CurrentFrame()
    at Zeta.Bot.BotMain.()
    at Zeta.Bot.BotMain.()

    [YetAnotherRelogger] System.Exception: Only part of a ReadProcessMemory or WriteProcessMemory request was completed, at addr: 01D8A880, Size: 56
    at GreyMagic.ExternalProcessMemory.ReadByteBuffer(IntPtr addr, Void* buffer, Int32 count)
    at GreyMagic.MemoryBase.Read[T](IntPtr addr)
    at Zeta.Game.Internals.ActivePlayerData.()
    at Zeta.Game.Internals.ActivePlayerData.get_IsNotInGame()
    at Zeta.Game.ZetaDia.get_IsInGame()
    at YARPLUGIN.YARPLUGIN.LogWorker() in c:\Users\Main\Desktop\DB\Plugins\YAR\Plugin.cs:line 422
     
  2. Defqon

    Defqon Member

    Joined:
    Dec 1, 2013
    Messages:
    382
    Likes Received:
    2
    Trophy Points:
    18
    Yep getting the exact same error
     
  3. KFING

    KFING New Member

    Joined:
    Apr 26, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    What do you think you are? Your are just nobody & nothing. So, stop barking.
     
  4. paki1987

    paki1987 New Member

    Joined:
    Sep 6, 2014
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    i got this working but i have a question how do you get this to work with Grift en normal Rift?
    i use the same profile for both and i'm a little confused on how it uses keys? or do i need separate rifting profiles?
    works great so far using it for farming blues Whites and keyruns and bounties
     
  5. leonistic

    leonistic New Member

    Joined:
    May 17, 2014
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    Can I run this with normal Trinity ? I can't seem to under how to get the Trinity Fork thingie working. Anybody got an extensive tutorial to install this? Ive downloaded but have no clue how to get it to work..
     
  6. leonistic

    leonistic New Member

    Joined:
    May 17, 2014
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    Seriously dude. There is no need to be this rude. Even if no one replies, wait for it or ask nicely again. I didn't get any replies in regards to my request for help too and I dont see me bitching about it like you do.
    Learn to respect others.
     
  7. paki1987

    paki1987 New Member

    Joined:
    Sep 6, 2014
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    To Leonistic Yes this works with normal trinity and latest demonbuddy
    i use this for farming blue and Whites + keyruns + bounties all the small stuff that doesnt really require trinity fork as much
    havn't figured out yet how to do normal rifts or greater rifts
     
  8. paki1987

    paki1987 New Member

    Joined:
    Sep 6, 2014
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    nevermind, using R-rift voor greater rift and Rift-bot profiles for T6
     
  9. amarelosmash

    amarelosmash New Member

    Joined:
    Apr 1, 2014
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Here the YAR doesn´t open..... i dont know what to do.... double click and nothing appears

    i´m using windows 8 x64...


    N [09/06/2015 11:19:50] System.Configuration.ConfigurationErrorsException: O sistema de configuração falhou ao inicializar ---> System.Configuration.ConfigurationErrorsException: Elemento raiz inexistente. (C:\Users\AMARELO\AppData\Local\YetAnotherRelogger\YetAnotherRelogger.exe_Url_4japzte3fzwqzqolytmrc1awodkcyn3r\1.1.0.0\user.config) ---> System.Xml.XmlException: Elemento raiz inexistente.
    em System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
    em System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    em System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
    em System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
    --- Fim do rastreamento de pilha de exceções internas ---
    em System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
    em System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
    em System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
    --- Fim do rastreamento de pilha de exceções internas ---
    em System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
    em System.Configuration.Internal.InternalConfigRoot.RemoveConfigImpl(String configPath, BaseConfigurationRecord configRecord)
    em System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
    em System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
    em System.Configuration.ConfigurationManager.GetSection(String sectionName)
    em System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
    em System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
    em System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
    em System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
    em System.Configuration.SettingsBase.get_Item(String propertyName)
    em System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
    em System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
    em YetAnotherRelogger.Program.Main()
    N [09/06/2015 11:19:50] Closed!
     
  10. Colaruot

    Colaruot New Member

    Joined:
    Sep 12, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    i have the same problem win 7 64x


    N [11.06.2015 11:26:29] System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Root element is missing. (C:\Users\Aari\AppData\Local\YetAnotherRelogger\YetAnotherRelogger.exe_Url_f1oq5bqxllhez23tfyohtbyzq3gjwk1k\1.1.0.0\user.config) ---> System.Xml.XmlException: Root element is missing.
    at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
    at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
    --- End of inner exception stack trace ---
    at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
    at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
    at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
    --- End of inner exception stack trace ---
    at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
    at System.Configuration.Internal.InternalConfigRoot.RemoveConfigImpl(String configPath, BaseConfigurationRecord configRecord)
    at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
    at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
    at System.Configuration.ConfigurationManager.GetSection(String sectionName)
    at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
    at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
    at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
    at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
    at System.Configuration.SettingsBase.get_Item(String propertyName)
    at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
    at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
    at YetAnotherRelogger.Program.Main()
    N [11.06.2015 11:26:29] Closed!
    N [11.06.2015 11:26:34] System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Root element is missing. (C:\Users\Aari\AppData\Local\YetAnotherRelogger\YetAnotherRelogger.exe_Url_f1oq5bqxllhez23tfyohtbyzq3gjwk1k\1.1.0.0\user.config) ---> System.Xml.XmlException: Root element is missing.
    at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
    at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
    --- End of inner exception stack trace ---
    at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
    at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
    at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
    --- End of inner exception stack trace ---
    at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
    at System.Configuration.Internal.InternalConfigRoot.RemoveConfigImpl(String configPath, BaseConfigurationRecord configRecord)
    at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
    at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
    at System.Configuration.ConfigurationManager.GetSection(String sectionName)
    at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
    at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
    at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
    at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
    at System.Configuration.SettingsBase.get_Item(String propertyName)
    at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
    at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
    at YetAnotherRelogger.Program.Main()
    N [11.06.2015 11:26:34] Closed!
     
  11. Vannaka

    Vannaka Member

    Joined:
    May 11, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Exactly the same has happened to me just now - been using it fine, have done clean installs and rebooted a few times.

    Also having DB not starting either.
     
  12. Vannaka

    Vannaka Member

    Joined:
    May 11, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Last edited: Jun 15, 2015
  13. vuwrr

    vuwrr Member

    Joined:
    Jan 15, 2010
    Messages:
    287
    Likes Received:
    1
    Trophy Points:
    18
    Not a programmer but would assume it has something to do with the config file, since it is XML, so try deleting it (or move it if you want to keep it for later?) and setting up R-YAR again.
     
  14. Vannaka

    Vannaka Member

    Joined:
    May 11, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Tried that a few times - Actually fixed this issue by moving the entire YAR folder over to a different drive
     
  15. Sleejer

    Sleejer New Member

    Joined:
    Jun 1, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Since today im getting the error "There is an error in XML document (0, 0)" when I try to start YAR.
    What could be causing this ?
     
  16. taozi

    taozi Community Developer

    Joined:
    Nov 10, 2012
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    18
    most likely your settings file was corrupted, you need to delete bots.xml in settings folder.

     
  17. Shaded

    Shaded Member

    Joined:
    Apr 18, 2011
    Messages:
    336
    Likes Received:
    0
    Trophy Points:
    16
    Is there a way to tell the relogger which D3 character to use?
     
  18. taozi

    taozi Community Developer

    Joined:
    Nov 10, 2012
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    18
    demonbuddy supports hero switching, so it is up to rrrix whether he wants to add this function or not.
     
  19. TwoCigars

    TwoCigars Active Member

    Joined:
    May 4, 2014
    Messages:
    992
    Likes Received:
    41
    Trophy Points:
    28
    I am having an issue with YAR that hits the STOP button on DB.

    ...The bot will be in the middle of clearing key runs, bounties, normal rifts and greater rifts when I will see the "LEAVING GAME..." message popup. This issue doesn't appear to be profile specific. It will occur right after killing enemies with gold and loot on the ground. It even happened while I watched gold tallying up in the bottom right corner of the screen.

    It seems to be rather random. I will be in game for 5 minutes, other times 10+hours. DB will clear 10 GRIFTs with no issue, then it will happen 2 GRifts in a row.

    [HR][/HR]

    I am using Beardi's Monk setup here: https://www.thebuddyforum.com/demon...5800-guide-season-3-monk-botting-t6-gr51.html

    The issue always happens right after this shows up in my log.
    [YetAnotherRelogger] Inserting YAR Hook
    [Trinity] Inserting GoldInactivity into TreeStart
    [Trinity] Inserting XPInactivity into TreeStart

    Clearly I thought something was "procing" my inactivity timer(s) for what I had deemed as a Critical Hit to my efficiency.

    Changed all of my inactivity settings out to 6 minutes, then 10, 15, even at max. Still was happening.
    Turned off Gold inactivity. Still caught it happening.
    Turned off Experience Inactivity. It happened again.
    I have turned on and off stat tracking in YAR.
    I have turned off all settings in YAR for inactivity.
    It still seems to happen anyways.

    Then I re-thought the message. It looks like YAR is restarting the session? I have my session length set to 20000 minutes, so that doesn't make sense.

    Has anyone else noticed this going on?

    Probably the most frustrating was the end of a few 50+ GRifts where it was nearly at the RG or fighting the RG and left the game.
     
    Last edited: Jun 21, 2015
  20. Shaded

    Shaded Member

    Joined:
    Apr 18, 2011
    Messages:
    336
    Likes Received:
    0
    Trophy Points:
    16
    Last edited: Jun 22, 2015

Share This Page