• Visit Rebornbuddy
  • [Release] RebornBuddy64 Version 1.0.232 - DirectX11 / x64 bit compatible

    Discussion in 'Rebornbuddy Forum' started by mastahg, Feb 29, 2016.

    1. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      In a quick search in the log attached above we see:

      39 hits for Lisbeth specific exceptions

      search> [Lis5.35f23][Error] System.Net.Http.HttpRequestException:​

      58 hits for RB exceptions while contacting authorization server

      search> System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://auth.cn.buddyauth.com:5031/AuthService.svc

      Maybe there's some other underlying issue but everything was working fine until about a week ago. Give or take...
       
    2. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      As indicated, use normal auth with 393
       
    3. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      And the fact that two unrelated services have connectivity issues leads me to believe this might not be fully an issue on our end.
       
    4. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      Ok. Ill swap back once everything's back online. Fingers crossed!
       
    5. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      I don't have any connectivity issues in any application except in RB. Connections are stable for all other web connected applications, including ffxiv itself.
       
    6. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      Could be either windows firewall, or windows defender killing the connection.
       
    7. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      Ill update exceptions for RB in those too then. Anything to try and solve this >.<
      Though you'd think it'd either connect or not, instead of intermittent issues.
       
    8. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      Just booted everything back up. Even before hitting the Start button in RB I have received the error

      [09:26:35.162 D] Exception while contacting authorization server.
      [09:26:35.165 D] System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://auth.eu.buddyauth.com:5031/AuthService.svc.
       
    9. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      Try the new build
       
    10. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      Still having issues after another extended session
      ~40 auth errors
      ~18 lisbeth connection errors
      There's definitely a drop in occurrences but small sample size is inconclusive.
       
    11. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      Need the log.
       
    12. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      Here we are. Even got the exception here after I stopped RB.
       

      Attached Files:

    13. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      Update to 394. It was pushed last night.
       
      Akira0245 likes this.
    14. roundcab

      roundcab New Member

      Joined:
      Oct 26, 2020
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      1
      Solid couple hours with no hitches! At least as far as logs show. Good sign!
       
    15. Zamphire

      Zamphire Member

      Joined:
      May 16, 2013
      Messages:
      269
      Likes Received:
      6
      Trophy Points:
      18
      Previously ActionManager.HasSpell returned true for Blue Magic spells even when they weren't set to active, assuming that you had learned them. However, it seems now it's required that they are set to active for it to return true. Was this an intended change?
       
      Last edited: Nov 3, 2020
    16. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      Hrm, not directly I guess, but hasspell's purpose is to only check for spells that the player could actively try casting, if a blue mage spell isn't selected then it wouldn't make sense for hasspell to return true for it. Blue probably needs an extra function for checking if its unlocked.
       
    17. Zamphire

      Zamphire Member

      Joined:
      May 16, 2013
      Messages:
      269
      Likes Received:
      6
      Trophy Points:
      18
      I assumed this was the case. One of those instances where "It shouldn't work, but it does" and then got fixed to work like it should. Is there any chance we can get a proper condition for checking Blue Magic Spells?

      I'd also really like to see support for Leve quests if that's possible. Picking up levels, turning them in, initiating them. I'm using modified versions of Exbuddy's tags right now, but they only half work. Any possibility you could work in official support for picking up, turning in, and initiating leve quests?
       
    18. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      I'll look into what's needed for blue mage stuff.


      Leve logic is absurdly complex behind the scenes, to get questing to work in a usable manner was a big endeavor, and supporting leve's would be an even bigger one.
       
    19. Zamphire

      Zamphire Member

      Joined:
      May 16, 2013
      Messages:
      269
      Likes Received:
      6
      Trophy Points:
      18
      I actually have about 20 combat leve quests already coded and successfully completed using Orderbot. I'm sure in the higher level stuff it gets more complicated, but at least for the level 40-50 leves I've done it's fairly straight forward. Would just be really nice to have a reliable turn in and initiate method. Oh, and a condition for "IsLeveQuestCompleted". The orderbot profiles I have now just rely on things being completed the first time around, which works about 90% of the time. Would be nice to have some conditions.
       
    20. mastahg

      mastahg Administrator Staff Member

      Joined:
      Feb 27, 2011
      Messages:
      4,575
      Likes Received:
      240
      Trophy Points:
      63
      New version adds ActionManager.KnownBlueMageSpells

      I'll think about the leve helpers
       
      Akira0245 likes this.

    Share This Page