Demonbuddy for Season 16 released, updates.buddyauth.com !
  • Visit Rebornbuddy
  • Visit Demonbuddy

2.5 Barbarian Leap/Quake Needed

Discussion in 'Archives' started by Helmet507, Jun 2, 2017.

  1. Helmet507

    Helmet507 Member

    Joined:
    Aug 21, 2015
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    6
    is there a better CR or can be modified to my build? i use warcry-vetrans instead of WotB-insanity.
     
    Last edited: Jun 2, 2017
  2. Shaziggle

    Shaziggle New Member

    Joined:
    May 31, 2017
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    I have changed a few spells around in these builds and the program seems to run them fine. Like I run the WW barb, but I don't use Ground stomp I use War Cry and it runs just fine.
     

Share This Page