Demonbuddy for Season 16 released, updates.buddyauth.com !
  • Visit Rebornbuddy
  • Visit Demonbuddy

RB closes randomly after the new patch

Discussion in 'Rebornbuddy Support' started by electrickfun, Jan 9, 2019.

  1. electrickfun

    electrickfun New Member

    Joined:
    Nov 28, 2018
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    The bot just closes randomly,doesnt give an error no nothing.
    Ill attach the last 2 logs i had this happen to me.
     

    Attached Files:

    Mika Mila likes this.
  2. mastahg

    mastahg Administrator Staff Member

    Joined:
    Feb 27, 2011
    Messages:
    3,963
    Likes Received:
    164
    Trophy Points:
    63
    Code:
    [07:22:15.076 N] [AuthCore] An error occurred while sending the request.
    
    Not sure what this is, could be a third party plugin closing RB. Don't see anything really strange in the second.

    Best bet is to try a clean install without adding anything and see if it crashes, if it doesnt slowly add stuff until it does.
     
    Mika Mila likes this.
  3. Jennifer Beard

    Jennifer Beard New Member

    Joined:
    Sep 19, 2018
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    I hope this helps. I was having the same issue with RebornBuddy force closing on me before it even fully loaded. I saved all of my old RB files onto a USB drive and did a fresh install. I then added each file back one by one, launching RB after each file transfer.

    Turned out for me that the Kefka file was causing it to force close. I don't understand why but it works for my boyfriend and not me. I even tried using his copy on my PC and it didn't work. Long story short, I unchecked Switcharoo under plugins since it kept defaulting to Kefka and now it works.
     
    Mika Mila likes this.
  4. zzi

    zzi Active Member

    Joined:
    Mar 10, 2016
    Messages:
    289
    Likes Received:
    41
    Trophy Points:
    28
    kefka stopped working when xivdb went down iirc.
     
    Mika Mila likes this.
  5. Jennifer Beard

    Jennifer Beard New Member

    Joined:
    Sep 19, 2018
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    Do you think there's a fix or a work around for this? I just can't understand why it won't work for me but it will work for someone else. Any thoughts?
     
    Mika Mila likes this.
  6. Freiheit

    Freiheit Member

    Joined:
    Apr 23, 2015
    Messages:
    44
    Likes Received:
    24
    Trophy Points:
    8
    Omni's version stopped working, my builds still perform as expected because they grab the action/status data from another source.
     
  7. Jennifer Beard

    Jennifer Beard New Member

    Joined:
    Sep 19, 2018
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    I’m new to this and educating myself. What do you mean they are grabbing from another source? If there a way for me to change my source so I can use Kefka again?
     
  8. Freiheit

    Freiheit Member

    Joined:
    Apr 23, 2015
    Messages:
    44
    Likes Received:
    24
    Trophy Points:
    8
    Omni's version queried the now defunct xivdb API, I generate and publish the data in a compatible format myself and have an automated process to push updates once a new patch hits. There is really nothing more to it.

    Not without either providing a new data source or disabling the download of the actions/status data via the source-code. Both solutions require you to rebuild Kefka yourself afterwards.
     
  9. Jennifer Beard

    Jennifer Beard New Member

    Joined:
    Sep 19, 2018
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    Oh... well thank you but, I’ll stick to letting developers do their handy work. Lol.
     

Share This Page